Finom and Swan Issue

Incident Report for finAPI Live

Resolved

Together with the service provider from Finom and Swan, we could solve the problem.
Posted Mar 24, 2025 - 16:00 CET

Identified

Currently for Finom and Swan payment submission and account information retrieval fail with error message "Given certificate could not be found.". We are already in contact with Finom and Swan technical team to resolve this issue. We'll keep you posted.
Posted Mar 21, 2025 - 08:58 CET
This incident affected: finAPI Live and finAPI Sandbox.