Revolut Issue

Incident Report for finAPI Live

Resolved

The connectivity issue affecting Revolut has been resolved. Account Information Services (AIS) and Payment Initiation Services (PIS) involving Revolut are operating normally again.

The issue was caused by a certificate-handling problem following a general infrastructure change. We corrected the configuration and verified that the service is working as expected.

To reduce the risk of similar issues in future releases, we are extending our validation to include dedicated connectivity checks for affected bank interfaces.

We apologize for the inconvenience.
Posted Aug 06, 2026 - 10:46 CEST

Investigating

We are currently experiencing connectivity issues with Revolut, which may impact our services.

As a result, Account Information Services (AIS) requests and Payment Initiation Services (PIS) requests involving Revolut may fail or be unavailable.

Our team is actively investigating the issue with the highest priority and is working to restore normal service as quickly as possible.

We will provide further updates as soon as more information becomes available.
Posted Aug 06, 2026 - 09:19 CEST
This incident affected: finAPI Live and finAPI Sandbox.