The issue was resolved by the XS2A API provider, and the banks can now be reached again.
Posted Dec 04, 2025 - 18:00 CET
Identified
According to our analysis due to a technical problem at Finom and Swan's PSD2 XS2A API provider, retrieving account information and submitting payments is currently failing. We have reported this problem to Finom and Swan's PSD2 XS2A API provider for resolution. We will announce when the problem has been resolved.
Posted Nov 28, 2025 - 14:02 CET
This incident affected: finAPI Live and finAPI Sandbox.