Revolut XS2A Import/Update failing

Incident Report for finAPI Live

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 12:01 CEST

Update

We are working on a solution and will keep you updated
Posted Sep 04, 2025 - 09:11 CEST

Identified

We see an issue at the connection with Revolut Bank accounts via XS2A.
Our development team is currently checking this and we will keep you informed.
Posted Sep 04, 2025 - 08:59 CEST
This incident affected: finAPI Live and finAPI Sandbox.